
 

 

AUDIO (Part 1) 
 
 
A. TEORI 
 
1. Suara 

 
Suara adalah  

o Sesuatu yang dihasilkan oleh getaran yang berasal dari benda bergerak. 

o Sesuatu yang menghasilkan bunyi  
o Sebuah tekanan gelombang udara, maka memiliki nilai kontinyu (analog).  

 
 
 
 
 
 

 

Suara berhubungan erat dengan rasa “mendengar”.  
Suara/bunyi biasanya merambat melalui udara. Suara/bunyi tidak bisa merambat melalui 
ruang hampa. 

 
KONSEP DASAR  
Suara dihasilkan oleh getaran suatu benda. Selama bergetar, perbedaan tekanan terjadi 
di udara sekitarnya. Pola osilasi yang terjadi dinamakan sebagai “GELOMBANG”. 
Gelombang mempunyai pola sama yang berulang pada interval tertentu, yang disebut 
sebagai “PERIODE”. 

Contoh suara periodik : instrument musik, nyanyian burung, dll.  
Contoh suara nonperiodik : batuk, percikan, ombak,dll 
 

 



 

 

 

Suara berkaitan dengan: 
 

1) Frekuensi 
 

 Banyaknya periode dalam 1 detik  
 Satuan: Hertz (Hz) atau cycles per second (cps) Jenis-jenis frekuensi : 

1. Infra sound 0 –20 Hz 

2. Pendengaran manusia 20Hz –20KHz 

3. Ultra sound 20 KHz-1 GHz 

4. Hyper sound 1 GHz-10 THz  
 Manusia bersuara dengan frekuensi : 50Hz –10KHz.  
 Suara musik memiliki frekuensi : 20Hz –20Khz.  
 Sistem multimedia menggunakan suara yang berada dalam range 

pendengaran manusia. 
 

2) Amplitudo 
 

 Keras lemahnya bunyi atau tinggi rendahnya gelombang. Satuan 

amplitudo= decibel (db) 

 Batas ambang pendengaran manusia:  
o 85 dB = merusak telinga 
o 130 dB = memecahkan gendang telinga 

 

3) Velocity 
 

 Kecepatan rambat gelombang bunyi sampai ke telinga pendengar. Satuan 

: m/s 

 Pada udara kering : suhu 20 °C = 343 m/s 

 
2. Audio  

 AUDIO : Suara yang berada pada range pendengaran manusia  
 ACCOUSTIC SIGNALS : gelombang audio  
 NOISE : Suara diluar audio (getaran yang tidak teratur dan tidak berurutan, tidak dapat 

didengar manusia). 

 PERIODE: gelombang yang berulang-ulang pada waktu tertentu. 



 

 

 Suara yang dapat didengar oleh manusia adalah berupa gelombang analog. Gambar 

gelombang analog: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

REPRESENTASI SUARA  
 Gelombang suara analog tidak dapat langsung direpresentasikan pada komputer. 

 

 Komputer mengukur amplitudo pada satuan waktu tertentu untuk menghasilkan 

sejumlah angka: SAMPLE 

 Audio digital dibuat saat mengonversikan sebuah gelombang suara kedalam angka 

dengan prosesnya digitizing (mendigitalkan). 

Kualitas recording digital : 
 

o Tergantung pada seberapa sering sampel diambil. 
 

o Berapa banyak angka yang digunakan untuk merepresentasikan nilai dari tiap 
sampel (bitdepth, ukuran sampel, resolusi, range dinamis) 

 
 

PENGANTAR ADOBE AUDITION 

 

1. Adobe Audition 
 

Adobe Audition merupakan suatu program yang digunakan untuk merekam, mengedit suara 
dalam bentuk digital yang berbasis Windows. Program ini dilengkapi dengan modul-modul efek 
suara, seperti Delay, Echo, Pereduksi Noise/Hiss, Reverb, Pengatur Tempo, Pitch, Graphic Dan 
Parametric Equalizer. 
 

Adobe Audition memberikan fasilitas perekaman suara sampai dengan 128 track hanya dengan 
satu sound card, hal ini akan memberikan kemudahan bagi seorang sound editor untuk 
berekspresi lebih jauh. Edit suara bisa dilakukan dalam bentuk .wav Dan penyimpanan bisa 
diconvert dalam bentuk format seperti .wma, .mp3, mp3pro, dll. Dalam arrangement sebuah 
musik bisa dilakukan dengan menambahkan beberapa alat musik dan dikoneksikan dengan line 
in atau michrophone dari soundcard. 



 

 

 

Contoh lain dalam proses perekaman yang terjadi dalam suatu radio seperti News (berita), 
umumnya melalui beberapa tahap :  

1. Tahap Take Voice. Tahapan ini berupa pengambilan suara-suara yang diperlukan sesuai 
dengan kebutuhan script. Pengambilan suara bisa dilakukan diluar (outdoor) studio atau 
di dalam studio (indoor). Untuk outdoor take voice dilakukan dengan sebuah alat perekam 
seperti tape recorder atau sejenisnya. Sedangkan untuk indoor dilakukan didalam studio 
misalnya take voice oleh presenter. Kelebihan dari take voice indoor akan dihasilkan 
kualitas suara yang lebih bagus kaena bebas dari suara-suara yang luar yang tidak perlu.  

2. Loading + Editing. Tahap ini memasukan suara hasil take voice kedalam perangkat editing. 
Dari perangkat ini suara akan diedit sesuai dengan kebutuhan, seperti menghilangkan 
noise, atau mengequalize suara sebelum di campur (mixing) dengan suara-suara lain. 

3. Mixing. Tahap pencampuran suara-suara sesuai dengan suara yang dibutuhkan 
berdasarkan kebutuhan script. Mengatur suara latar (back sound misalnya music, effect, 
smash dan lain sebagainya), level volume suara dilakukan di tahap ini.  

4. Transfering. Memindahkan suara hasil mixing ke media penyimpanan seperti kaset, 
harddisk, dan lain sebagainya. 

 

Untuk semua tahapan diatas dapat dilakukan dengan sebuah alat bantu Digital Sound Editor (DSE) 
yaitu Adobe Audition yang bekerja di sebuah perangkat Personal Computer. Program DSE banyak 
sekali macamnya seperti Cool Edit, Soundforge, Mix Vibes, Adobe Audition, dan masih banyak 
yang lainnya. Dari semua DSE mempunyai kekurangan dan kelebihan masing-masing. Beberapa 
kelebihan atau fasilitas yang disediakan Adobe Audition :  

1. Multitrack Editing dan Mixing sampai 128 track 
2. Lebih dari 40 data sound effect, mastering, perangkat analisa editing suara terdapat 

didalamnya, semua ini termasuk Echo, Reverb, Flanging, Chorusing, Compression, 
Limiting, Equalization, Noise Reduction, dan lainnya.  

3. Pengorganisasian track yang lebih mudah  
4. Support untuk banyak format audio  
5. Visualisasi dari gelombang suara analisa dalam bentuk angka  
6. Proses editing dilakukan dengan klik & drag 

 

 

Filosofi Kerja Adobe Audition 
 

Pengolahan File 

 

Sebelum bekerja dengan Adobe Audition lebih jauh, ada baiknya memahami lebih dahulu 
bagaimana konsep kerja dari Adobe Audition. Seperti halnya dalam membangun suatu rumah, 
beberapa perancangan dan faktor-faktor pendukung harus dipikirkan terlebih dahulu, agar 
tercipta suatu bangunan yang kokoh dan enak dilihat. Begitu juga untuk merekam suara perlu 
diperhatikan apa yang akan dihasilkan, bentuknya seperti apa, faktor pendukung dari hasil akhir 
yang akan digabungkan, hal ini agar seorang sound editor tidak kebingungan ditengah jalan 
karena tidak ada patokan-patokan atau rule yang akan dilaksanakan. 
 

Satu titik kunci dalam pengeditan adalah mahir dalam pengolahan editing gelombang suara yang 
bersifat desctructive dan non destructive. Destructive dalam hal ini berarti pengeditan yang bisa 
merubah dengan cara menambah, memotong, memodifikasi (cutting, pasting, adding 



 

 

reverb, etc) dari gelombang suara sehingga bisa merubah dari yang aslinya. Non Destructive 
dalam hal ini editing suara yang tidak mengubah model aslinya seperti halnya equalisasi (volume, 
bass, treble). 
 

Tampilan Hasil Langsung Terlihat 

 

Semua hasil editing suara yang telah dilakukan bisa langsung ditampilkan dalam bentuk 
gelombang suara dan audio yan keluar dari speaker. 
 

 

File Kerja 

 

Seperti halnya video soundtrack atau Midi, Adobe Audition mempunyai file kerja yang disebut 
dengan file session (.ses). Ini memudahkan bila kita akan bekerja dengan beberapa track suara. 
Sebagai contoh seorang sound editor bekerja dengan dua track vocal dan gitar. Kemudian hasilnya 
kita simpan dalam dua file .wav dan .ses, Perbedaan dari kedua file tersebut untuk  
.wav, vocal dan gitar akan bergabung jadi satu, sehingga untuk pengeditan ulang tidak bisa satu-
satu, tetapi untuk .ses bisa diedit kapan aja untuk satu track misalnya guitar saja atau vocal saja. 
 

 

FUNGSI DASAR REKAM EDIT DAN MIXING 

 

2. Prinsip Dasar Gelombang Suara 
 

Sebenarnya apakah suara itu? Bagaimana suara dapat didengar dan ditangkap oleh telinga kita? 
Pada dasarnya suara dihasilkan ketika udara mengalami gangguan dari benda yang bergetar dan 
getaran itu sampai ke gendang telinga kita. Benda ini bisa berupa tenggorokan manusia, senar 
gitar, udara di sekeliling senar gitar tersebut mengalami gangguan sehingga menghasilkan getaran 
yang ditangkap sebagai suatu bunyi oleh gendang telinga kita . Apabila kita berbicara atau 
menyanyi, tenggorokan yang bergetar menyebabkan udara yang lewat mengalami gangguan 
sehingga menghasilkan suara juga. 
 

Getaran benda tersebut harus cukup kuat yaitu setidaknya 20 kali per detik agar kita dapat 
mendengarnya sebagai suatu bunyi. Bila kurang dari jumlah itu, kita tidak akan mendengarnya 
sebagai suat bunyi. Banyaknya getaran suatu benda diukur dengan satuan cycles per second atau 
cps. 
 

Pengukuran ini juga dikenal dengan sebutan Hertz atau Hz. Kadang-kadang benda bergetar sangat 
cepat yaitu sampai ribuan getaran per detik. Untuk mengukurnya digunakan satuan KiloHertz per 
detik atau kHz. Daya tangkap pendengaran manusia secara teoritis adalah dari 20Hz sampai 20 
kHz, tetapi pada kenyataannya getaran yang paling tinggi yang dapat didengar manusia adalah 
antara 15 sampai 17 kHz. 
 

 

3. Digital Recording 
 

Digital Audio adalah cara komputer merepresentasikan gelombang suara menjadi sederetan 
angka yang diistilahkan sebagai bilangan biner yaitu bilangan yang terdiri dari angka 1 dan 0. 
Proses perekaman yang prosesnya mengubah sinyal Analog to Digital Conversion atau biasa 
disingkat A-to-D conversion. Proses ini disebut sebagai sampling. Kemampuan ini biasanya ada 



 

 

pada Sound card komputer. Mikrofon dalam kerjanya menangkap getaran suara yang 
dierjemahkan dalam bentuk gelombang suara melalui soundcard komputer. 
 

Digital recording mempunyai beberapa keuntungan dibandingkan analog recording yaitu dalam 
hal kualitas suara dan kebebasan untukimelakukan penggandaan. Pada saat merekam data audio, 
kita bisa memilih sampling rate yaitu tingkat atau kualitas perekaman data audio oleh komputer. 
Sebagai contoh lima jenis sampling rate yaitu : 11025 Hz, 22050 Hz, 44100 Hz, 48000 Hz, dan 
96000 Hz. 
 

Pada sampling rate 11025 Hz, kualitas suaranya kira-kira setara dengan lawan bicara ketika bicara 
di telepon. Pada 22050 Hz, setara dengan kualitas suara radio atau kaset lagu. Pada 44100 Hz, 
setara dengan kualitas CD audio. Sampling Rate 48000 Hz, saat ini masih belum digunakan 
walaupun ada beberapa alattertentu yang menggunakannya. Sedangkan 96000 Hz disediakan 
Adobe Audition untuk mengantisipasi perkembangan teknologi audio yang menuntut kualitas 
suara yang semakin sempurna. Semakin tinggi smpling rate, semakin baik kualitas suara tetapi 
juga semakin besar memori dan ruang harddisk yang dibutuhkan juga kerja prosessor yang 
semakin intensif. 
 

Dibawah ini menunjukan kebutuhan ruang hardisk untuk satu menit data audio pada berbagai 
sampling rate secara teoritis : 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Soundcard Half Duplex dan Full Duplex 
 

Dalam digital recording, ada beberapa hal yang harus diperhatikan mengenai soundcard yang kita 
pakai, apakah menggunakan soundcard yang halfduplex atau full-duplex. Apabila menggunakan 
soundcard half-duplex kita tidak dapat mendengarkan playback track audio yang sudah direkam 
sebelumnya, pada saat merekam track audio yang baru. Artinya soundcard tidak dapat melakukan 
playback dan recording data audio pada saat yang bersamaan. Tetapi untuk fullduplex 
mempunyai kemampuan sebaliknya. Untuk mengetahui jenis soundcard bisa dilihat di buku 
manualnya. 
 

 

5. Koneksi untuk Input Audio 

 

Pada bagian sound card terdapat beberapa jalur untuk input dan output audio. Input audio pada 
souncard tersebut digunakan untuk merekam data audio. Umumnya input audio ini terdiri dari 



 

 

mic in dan line in. Mic ini digunakan untuk merekam data audio yang berasal dari instrumen musik 

seperti gitar listrik atau bass listrik melalui kabel audio biasa. Pastikan untuk menggunakan kabel 

yang bagus kaena kualitas perekaman tergantung pula pada alat-alat ini. 
 

 

6. Mengatur Input level 
 

Pengaturan input level sangat penting sekali dilakukan, untuk menentukan seberapa keras track 
audio ini akan direkam, karena jika input level terlalu besar maka suara yang dihasilkan akan 
pecah (distorted), sedangkan bila terlalu kecil maka suara yang direkam akan banyak mengandung 
suara desis (noise). Untuk pengaturan input level, langkah-langkahnya adalah :  

1. Pastikan icon speaker tampak pada taskbar window di ujung kanan bawah, kemudian 
klik ganda icon tersebut maka akan muncul 

2. Pastikan untuk speaker Adobe Audition tidak dimute  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Atur pengatur volume untuk Microphone pada speaker preperties untuk menghasilkan 

suara yang diinginkan. 
 



 

 

4. Apabila menginginkan merekam dari mikrofon, tancapkanlah kabel mikrofon ke mic-in 
soundcard. Demikian pula jika ingin merekam dari instrumen musik yang menggunakan 
kabel seperti gitar atau bass listrik, tancapkanlah kabel dari gitar tersebut ke line-in 
soundcard tersebut. Aturlah volume pada play control / volume control  

5. Klik ganda lagi icon speaker pada taskbar. Dilayar akan tampak jendela volume control 
yang kedua. Klik menu Option, Properties, lalu klik pilihan Recording untuk menampilkan 
Record Control. Jangan lupa aktifkan pengatur volume untuk line ini dan mikrofon. 

 
Yang perlu diperhatikan bahwa play control atau volume control, hanya dipergunakan 
untuk mengatur keras pelannya suara yang keluar dari speaker atau sebagai pengatur 
output suara dan tidak berpengaruh pada saat perekaman. 

 
 
C. PRAKTEK 
 

1. Memainkan file suara 

 
 Untuk memulai latihan bukalah dokumen yang ingin anda mainkan dengan 

menggunakan menu File > Open. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Karena stereo maka pada Waveform Display akan terlihat bentuk waveform yang 

terdiri dari dua bagian. Bagian atas menunjukkan channel kiri dan bawah berarti 

channel kanan. 



 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Waveform Display 

 

 Anda dapat mendengarkan suara seluruh waveform dengan menekan tombol 
Play, dan Playback cursor akan berjalan dari kiri ke kanan. 

 

 

2. Menyeleksi Waveform 
 

Berikutnya Anda dapat menyeleksi sebagian waveform dengan klik tombol kiri dan drag ke 
kanan atau kiri. Maka akan terlihat blok dengan warna lain. Tekan tombol Play lagi untuk 
memainkan sebagian waveform. Anda dapat pula menyeleksi sebagian waveform pada salah 
satu channel dengan cara sama. Arahkan pointer ke bagian atas channel kiri untuk memilih 
channel kiri saja, atau bagian bawah channel kanan untuk memilih channel kanan saja.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Melakukan editing dasar 
 

Setelah Anda dapat menyeleksi waveform, kini Anda dapat berlatih untuk melakukan editing 
dasar, yaitu Cut, Copy, Paste dan Mix. Copy berguna untuk memindahkan bagian waveform 
yang terseleksi ke dalam internal clipboard. Cut berguna untuk memotong bagian waveform 
yang diseleksi dan memindahkannya ke dalam internal clipboard. Paste berguna untuk 
menambahkan data dari internal clipboard pada insertion point atau menggantikan bagian 
waveform yang terseleksi. Mix Paste hampir sama dengan Paste, bedanya Mix Paste akan 
mencampur antara waveform yang terseleksi atau mulai insertion point dengan data internal 
clipboard. 



 

 

Cut 

 

Anda dapat menyeleksi sebagian waveform, misalnya bagian akhir. Dan kemudian 
gunakan menu Edit > Cut. Maka bagian waveform yang terseleksi akan hilang, dan 
perhatikan panjang waveform setelah dipotong. Tekan tombol Play untuk mendengarkan 
hasilnya.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Menyeleksi bagian akhir waveform  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Waveform setelah dipotong dengan Cut 

 

 

Paste 

 

Berikutnya Anda dapat memindahkan data dari internal clipboard pada satu titik tertentu 
atau menggantikan bagian waveform yang terseleksi. Anda dapat memindahkan pointer 
ke posisi ke 0:05.000. Kemudian gunakan menu Edit > Paste.  



 

 

Menambah waveform dengan Paste 
 

Perhatikan waveform bertambah panjang. Dan tekan tombol Play untuk mendengarkan 
hasilnya. Selain itu Anda dapat menyeleksi bagian waveform dahulu. Kemudian 
menggantikan bagian waveform yang terseleksi dengan data dari internal clipboard 
dengan menu Edit > Paste. Kemudian tekan tombol Play untuk mendengarkan hasilnya. 

 

 

Mix Paste 

 

Gunakan menu Edit > Mix Paste atau Ctrl+Shift+V. Maka akan muncul Mix Paste Dialog 
dimana Anda dapat mengatur setting pencampuran waveformnya. Kemudian akhiri 
dengan menekan tombol OK. Tekan tombol Play untuk mendengarkan hasilnya.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

4. Merekam Suara 
 

 Set audio inputs (Lihat konfigurasi audio input dan output) Buat file baru dengan 

menu File > New > Audio File 

 Atur settingnya sesuai dengan sumber suaranya dan akhiri dengan menekan 

tombol OK. 
 



 

 

 Anda dapat mulai merekam dengan menekan tombol Record dan hentikan dengan 

menekan tombol Record sekali lagi. Dan, untuk mendengar hasilnya tekan tombol 

Play. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Setelah itu Anda dapat menyimpan hasilnya: File > Save As.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

5. Menambah/mengurangi volume 
 

Anda dapat menambah/ mengurangi volume waveform dengan menu Effects > Amplitude and 
Compression > Amplify. Kemudian Anda dapat menggeser slider pada Amplification ke kanan 
(+) untuk menambah volume dan ke kiri (-) untuk mengurangi volume. Dan dengarkan hasilnya 
dengan menekan tombol Preview. 



 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

6. Menambah efek suara 
 

Menambah efek suara dengan Effects Salah satu keunggulan Adobe Audition adalah dalam 
pengolahan dan penambahan berbagai efek suara. Contohnya dengan menambahkan efek 
suara Robot. Untuk itu Anda dapat menyeleksi dahulu sebagian atau seluruh waveform, 
kemudian gunakan menu Effects > Delay and Echo > Analog Delay. Kemudian Anda dapat 
memilih Robot Voice pada Presets.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Anda dapat mencoba efek yang lain pada menu yang sama atau pada menu Effects > Delay and 

Echo > Delay atau pada menu Effects > Delay and Echo > Echo. Untuk itu Anda dapat 
membatalkan perintah terakhir dengan Undo. 



 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

D. TUGAS 

 

Buatlah rekaman suara yang berisi informasi mengenai biodata anda dan berikan efek pada 
hasil rekaman sehingga menjadi lebih menarik. Pada rekaman sisipkan lagu favorit Anda. 


