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PENDAHULUAN 
 
 

Sistem Informasi Geografi (SIG) merupakan suatu kesatuan sistem (berbasis komputer) 

untuk pengelolaan, penyimpanan, pemrosesan, analisis, dan penayangan (display) data yang terkait 

dengan permukaan bumi. SIG akhir-akhir ini mengalami perkembangan yang pesat seiring dengan 

kemajuan dalam bidang teknologi informasi. Di Indonesia, bergulirnya otonomi daerah beberapa 

tahun yang lalu serta peningkatan kebutuhan akan informasi kebumian dalam rangka pengelolaan 

sumberdaya alam menjadi salah satu pemicu peningkatan penggunaan SIG. SIG telah banyak 

digunakan dalam kehidupan sehari-hari di berbagai bidang, bahkan bagi sebagian besar kalangan, 

SIG telah menjelma menjadi suatu kebutuhan yang tidak dapat ditinggalkan. 

SIG terdiri dari beberapa komponen utama, yaitu: perangkat keras (hardware), perangkat 

lunak (software), data, orang (SDM), dan prosedur/manajemen. Bahkan di era komunikasi global 

saat ini jaringan (network) dapat ditambahkan ke dalam komponen utama SIG. Banyak kalangan 

memanfaatkan jaringan internet untuk aktivitas tukar-menukar informasi spasial sehingga muncul 

instilah SIG berbasis web atau sering dikenal sebagai webgis. Sebagai sebuah sistem, SIG memiliki 

beberapa kemampuan atau fungsi, diantaranya adalah: input data, manipulasi data, manajemen/ 

pengelolaan, query dan analisis, hingga kemampuan untuk visualisasi data dan informasi sebagai 

keluaran. Dengan beberapa kemampuannya tersebut, SIG telah diakui secara global dapat 

memberikan manfaat yang besar bila diterapkan dalam studi maupun analisis di berbagai bidang. 

Untuk memahami SIG secara menyeluruh, diperlukan pengetahuan yang berimbang 

mengenai teori maupun teknis atau prakteknya (skill). Oleh karena itu dalam modul praktikum ini 

akan dijabarkan langkah-langkah tentang penggunaan SIG tingkat dasar menggunakan salah satu 

perangkat lunak SIG yang masih banyak digunakan oleh berbagai kalangan di Indonesia, yaitu 

ArcView. Adapun materi teknis SIG yang akan diberikan dalam praktikum SIG 1 ini secara umum 

meliputi: input data, pengelolaan data (editing objects & atributes), serta pembuatan output/ 

keluaran SIG berupa peta. 

Modul praktikum SIG I ini terdiri dari 3 bab. Pada Bab I, akan dijelaskan tentang konsep GPS 

dan cara penggunaannya dalam hubunganya dengan pemetaan dan SIG, Bab II berisi langkah- 

langkah penggunaan ArcView untuk proses input data, editing data, hingga keluaran data,  

sedangkan pada Bab III akan dijelaskan tentang pemodelan SIG sederhana memanfaatkan 

kemampuan geoprocessing untuk overlay peta. Diharapkan dengan adanya modul praktikum ini 

mahasiswa akan lebih memahami mengenai konsep SIG serta memiliki kemampuan teknis yang baik 

sehingga dapat mempergunakannya untuk berbagai keperluan di masa yang akan datang. 
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BAB I   

PENGENALAN GPS 

 
1.1. Pengertian GPS 

GPS adalah singkatan dari Global Positioning System yang merupakan sistem untuk 

menentukan posisi dan navigasi secara global dengan menggunakan bantuan sistem satelit. Sistem 

ini dikembangkan pertama kali oleh Departemen Pertahanan Amerika dan digunakan untuk 

kepentingan militer maupun sipil (survey dan pemetaan). 

Sistem GPS atau NAVSTAR GPS (Navigation Satellite Timing and Ranging Global Positioning 

System), terdiri dari tiga segmen, yaitu: satelit, pengontrol, dan penerima/pengguna. Ada 24 buah 

satelit GPS yang mengorbit bumi dimana 21 satelit aktif bekerja sedangkan 3 satelit berfungsi 

sebagai cadangan. Masing-masing satelit memiliki orbit dan kedudukan yang tetap (koordinatnya 

pasti). 

a. Satelit bertugas untuk menerima dan menyimpan data yang ditransmisikan oleh stasiun- 

stasiun pengontrol, menyimpan dan menjaga informasi waktu berketelitian tinggi 

(ditentukan dengan jam atomic di satelit), dan memancarkan sinyal dan informasi secara 

kontinyu ke pesawat penerima (receiver) dari pengguna. 

b. Pengontrol bertugas untuk mengendalikan dan mengontrol satelit dari bumi, baik untuk 

mengecek kesehatan (kondisi) satelit, penentuan dan prediksi orbit dan waktu, 

sinkronisasi waktu antar satelit, dan mengirim data ke satelit. 

c. Penerima/Pengguna bertugas menerima data dari satelit dan memprosesnya untuk 

menentukan posisi (posisi tiga dimensi, yaitu koordinat di bumi plus ketinggian), arah, 

jarak, dan waktu yang diperlukan oleh pengguna. Ada dua macam tipe penerima, yaitu 

tipe NAVIGASI dan tipe GEODETIC, yang termasuk tipe navigasi antara lain: Trimble 

Ensign, Trimble Pathfinder, Garmin, Sony, dan lain sebagainya. Sedangkan tipe geodetic 

antara lain: Topcon, Leica, Astech, Trimble 4000, dan lainnya. 

 
Pada dasarnya penentuan posisi dengan GPS adalah pengukuran jarak secara bersama-sama 

ke beberapa satelit (yang koordinatnya telah diketahui) sekaligus. Untuk menentukan koordinat 

suatu titik di bumi, receiver setidaknya membutuhkan 4 satelit yang ditangkap sinyalnya dengan 

baik. Secara default, posisi atau koordinat yang diperoleh bereferensi ke global datum, yaitu World 

Geodetic System 1984 atau disingkat WGS’84. dibagi menjadi dua metode, yaitu metode absolut  

dan metode relatif. 



 

 

3 

 
 

a. Metode absolut atau juga dikenal dengan point positioning adalah menentukan posisi 

hanya berdasarkan pada 1 pesawat penerima (receiver) saja. Ketelitian posisi dalam 

beberapa meter (tidak berketelitian tinggi) dan umumnya hanya diperuntukkan bagi 

keperluan navigasi. 

b. Metode relatif atau sering disebut differential positioning adalah menentukan posisi 

dengan menggunakan lebih dari satu receiver. Satu GPS dipasang pada lokasi tertentu di 

muka bumi dan secara terus menerus menerima sinyal dari satelit dalam jangka waktu 

tertentu dijadikan sebagai referensi bagi yang lainnya. Metode ini menghasilkan posisi 

berketelitian tinggi (umumnya kurang dari 1 meter) dan diaplikasikan untuk keperluan 

survey geodesi atau pemetaan yang memerlukan ketelitian tinggi. 

 
Agar dapat menggunakan GPS secara optimum, pengguna juga perlu mengenal tentang 

sistem koordinat. Setidaknya ada dua klasifikasi tentang sistem koordinat yang dipakai oleh GPS 

maupun dalam pemetaan, yaitu: sistem koordinat global atau yang biasa disebut sebagai koordinat 

geografi dan sistem koordinat di dalam bidang proyeksi. 

a. Koordinat Geografi diukur dalam lintang dan bujur dalam besaran derajat desimal, 

derajat menit desimal, atau derajat menit detik. Lintang diukur terhadap ekuator 

sebagai titik NOL (00 sampai 900 positif kearah utara dan 00 sampai 900 negatif kearah 

selatan ). Bujur diukur berdasarkan titik NOL di Greenwich  00 sampai 1800 kearah 

timur dan 00 sampai 1800 kearah barat. 

b. Koordinat di dalam bidang proyeksi merupakan koordinat yang dipakai pada sistem 

proyeksi tertentu. Umumnya berkaitan erat dengan sistem proyeksinya, walaupun 

adakalanya digunakan koordinat Geografi dalam bidang proyeksi. Beberapa sistem 

proyeksi yang lazim digunakan di Indonesia antara lain: proyeksi Mercator, Transverse 

Mercator (TM), Universal Transverse Mercator (UTM), kerucut konformal, dan lainnya. 

Masing-masing sistem tersebut memiliki kelebihan dan kekurangan dan pemilihan 

proyeksi umumnya didasarkan pada tujuan peta yang akan dibuat. Dari beberapa sistem 

proyeksi tersebut, yang paling banyak dipakai di Indonesia adalah TM dan UTM. Peta- 

peta produksi Dinas Hidro Oseanografi (DISHIDROS) umumnya menggunakan proyeksi 

TM dengan sistem koordinat geografi atau UTM atau gabungan keduanya. Sedangkan 

peta-peta produksi Bakosurtanal atau sekarang bernama BIG (Badan Informasi 

Geospasial) umumnya menggunakan proyeksi UTM dengan sistem koordinat UTM atau 

geografi atau gabungan keduanya. 
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Membicarakan tentang sistem koordinat dalam bidang proyeksi tidak bisa lepas dari datum 

yang digunakan. Ada dua macam datum yang umum digunakan dalam perpetaan, yaitu datum 

horisontal dan datum vertikal. Datum horisontal dipakai untuk menentukan koordinat peta (x,y) 

sedangkan datum vertikal untuk menentukan elevasi (peta topografi) ataupun kedalaman (peta 

batimetri). Perhitungan dilakukan dengan transformasi matematis tertentu. Dengan demikian 

transformasi antar datum, antar sistem proyeksi, dan antar sistem koordinat dapat dilakukan. Untuk 

datum horisontal, peta-peta kita umumnya menggunakan datum Padang (ID-74) untuk peta-peta 

Bakosurtanal, dan menggunakan datum Jakarta (Batavia) untuk peta-peta Dishidros. 

Demikian sedikit pengantar mengenai GPS dalam hubungannya dengan kegiatan survey dan 

pemetaan. Yang perlu diingat dan diperhatikan dalam penggunaan GPS adalah mengenai datum, 

sistem proyeksi, dan sistem koordinat peta kerja yang digunakan. Dengan demikian GPS dapat diatur 

sedemikian rupa sehingga sesuai dengan tujuan penggunaan serta dapat meminimalisir tingkat 

kesalahan yang terjadi dalam pengukuran. 

 
1.2. Cara Penggunaan GPS 

Ada berbagai macam tipe/merk GPS receiver. Berikut ini akan diberikan panduan 

penggunaan GPS menggunakan salah satu tipe GPS navigasi yang saat ini cukup banyak digunakan 

dalam kegiatan survey dan pemetaan, yaitu GARMIN GPSMAP 76 CSx. Namun demikian pada 

dasarnya hampir setiap tipe/merk GPS memiliki prinsip, fungsi, fasilitas, dan cara penggunaan yang 

sama. Dengan demikian panduan penggunaan GPS ini juga dapat digunakan untuk pedoman bagi 

jenis GPS navigasi yang lainnya. 

 
 

 
Gambar 1.1. Bentuk Fisik GARMIN GPSMAP 76 CSx beserta Tombol-tombol dan Fungsinya 
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MEMPELAJARI FUNGSI TOMBOL 

Power Key  :  Tekan dan tahan untuk menghidupkan atau mematikan unit. Tekan dan lepaskan  

untuk mengatur lampu backlight dan kecerahannya. 

IN/OUT Key : Dari halaman peta, tekan untuk memperbesar atau memperkecil tampilan halaman 

peta. Dari halaman lain, tekan ke atas atau ke bawah untuk memilih daftar. 

Find Key : Tekan dan lepaskan untuk melihat dan menemukan tempat yang Anda cari, seperti : 

Waypoint, Restoran, Bank, Hotel, dll. Tekan dan tahan untuk feature MOB (Main 

Over Board). 

Quit Key : Tekan dan lepaskan untuk membatalkan atau balik ke halaman sebelumnya. 

Page Key : Tekan untuk menuju ke halaman berikutnya dan halaman utama 

Menu Key : Tekan untuk melihat menu dari masig-masing halaman. Tekan dua kali untuk masuk 

ke halaman utama. 

Enter Key : Tekan untuk memilih data yang tersorot atau untuk mengkonfirmasi pesan yang 

tampil di layar atau bisa digunakan untuk menyimpan Waypoint. 

Rocker Key : Tekan ke atas, bawah, kiri, atau kanan untuk memilih karakter pada daftar, meyorot 

data, atau menggerakkan panah pada halaman peta. 

 
PEMASANGAN BATERAI 

GPSMAP 76 CSx bekerja menggunakan 2 baterai AA (tidak termasuk). Baterai Alkaline atau 

NiMH dapat digunakan untuk alat ini (Lihat buku petunju untuk melihat tipe baterai). Data-data yang 

tersimpan tidak akan hilang pada saat penggantian baterai. Cara pemasangan baterai adalah sebagai 

berikut: 

1. Buka tutup tempat baterai dengan mengangkat cincin (bentuknya seperti huruf D), putar ¼ 

putaran berlawanan arah jarum jam, kemudian angkat penutupnya. 

2. Masukan kedua baterai, perhatikan kutub-kutubnya. 

3. Pasang kembali penutup baterai. Pastikan tertutup dengan benar (putar kembali cincin 

searah jarum jam). 

Sebagai catatan: 

- Hanya menggunakan baterai baru atau baterai yang telah diisi penuh ketika mengganti 

baterai. 

- Jangan memasang baterai Alkaline dengan NiMH secara bersamaan. 

- Baterai biasa biasanya lebih tahan lama digunakan daripada baterai yang dapat diisi ulang. 

- Penggunaan Backlight, WASS, atau ‘tone’ tombol akan mengurangi daya tahan baterai. 
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MENGAWALI GPS 

Sebelum dapat memulai menggunakan GPS Anda, Anda harus menunggu untuk penginstalan 

GPS. Proses ini memungkinkan GPS untuk menerima dan menyimpan informasi satelit untuk 

kenyamanan navigasi Anda. Proses penginstalan berlangsung secara otomatis dan tidak memakai 

waktu lama. 

 
Menginstal GPS (mencari satelit) 

1. Bawa GPS Anda ke tempat terbuka (tidak di dalam ruang/gedung tertutup) dan nyalakan. 

Ucapan ‘Welcome’ akan muncul disusul oleh halaman satelit. 

2. Tunggu sejenak sementara GPS Anda mencari sinyal satelit. Dalam proses ini Anda akan 

melihat tulisan ‘Acquiring Satelite’ di layar. 

3. Begitu GPS Anda telah mendapatkan sinyal dari satelit, koordinat lokasi Anda akan muncul di 

atas layar. 

 

 
Jika suatu saat GPS Anda tidak dapat mengumpulkan informasi satelit yang dibutuhkan, 

cobalah untuk menghindar dari gedung tinggi, pohon, atau gangguan lain. Lihatlah ke buku panduan 

untuk petunjuk yang lebih lengkap. 

 
Mengatur Lampu Backlight dan Tingkat Kecerahan 

Jika Anda tidak dapat melihat denngan jelas layar pada GPS, aturlah tingkat kecerahan dan 

lampu backlightnya. 

1. tekan tombol POWER dan lepaskan 

2. tekan tombol ROCKER ke atas/bawah untuk menambah/mengurangi tingkat kecarahan 

layar. 

3. Tekan tombol ROCKER ke kiri/kanan untuk mengganti kontras pada layar. Tekan quit untuk 

keluar. 
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MELIHAT HALAMAN UTAMA 

GPS Anda menunjukkan semua informasi yang Anda perlukan untuk navigasi 6 halaman 

utama (pada layar) : Halaman Satelite, Perjalanan Komputer, Peta, Kompas, Altimeter, dan Halaman 

Utama. Tekan tombol PAGE untuk melihat masing-masing halaman yang diinginkan. 
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MEMASUKAN DATA 

Untuk memasukkan atau mengganti data, tekan tombol ROCKER ke kiri, kanan, atas, dan 

bawah untuk menyorot sebuah data yang ingin Anda ubah. Tekan ENTER untuk memilihnya. 

Kemudian gunakan tombol ROCKER untuk memilih pilihan dari menu dan tekan ENTER. 

 
Mungkin Anda perlu memasukkan kata atau angka, hal ini dilakukan  

dengan tombol ROCKER dan sebuah keyboard akan tampil pada layar. 

Gunakan tombol ROCKER untuk menyorot sebuah huruf atau angka. Tekan 

ENTER untuk memilihnya. Lanjutkan menyorot dan memilih huruf/angka. 

Ketika Anda sudah selesai, sorot “OK” dan tekan ENTER. 

 
 
 
 

MENANDAI SEBUAH ‘WAYPOINT’ 

“Waypoint” adalah beberapa titik pada peta yang Anda simpan. Anda dapat membuat 

(menAndai) sebuah ‘waypoint’ pada posisi Anda saat ini dengan menulis ‘waypoint’, dan disimpan 

untuk digunakan dalam rute(lihat juga membuat Rute). 

 
Cara membuat “Waypoint” 

1. Dari halaman peta, tekan tombol ENTER dan tahan. Halaman ‘mark waypoint’ akan muncul 

2. Untuk menamai ‘waypoint’ adan, gunakan tombol ROCKER untuk menyorot area ‘NAME’  

dan tekan ENTER. 

3. Masukan sebuah nama untuk ‘waypoint’ Anda 

4. Pada keyboard dengan menggunakan tombol ROCKER dan ENTER (lihat cara memasukan 

data) 

5. Sorot ‘OK’ dan tekan ENTER untuk menyimpan ‘waypoint’. 
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Membuat dan Melihat Lintasan (Tracks) 

1. Tekan tombol PAGE sampai Anda menemukan halaman peta. 

2. bergeraklan dari posisi Anda sekurang-kurangnya 4 menit. 

3. Tekan IN untuk memperbesar halaman peta samapai Anda dapat melihat “Track Log” Anda. 
 

 
MENEMUKAN TEMPAT (Find) 

Dengan menekan tombol FIND, Anda dapat mencari waypoint, titik geochace, atau sebuah 

kota. Jika Anda memasukan MapSource pada GPS Anda, Anda akan dapat mencari lokasi rumah 

makan, penginapan, bank, pom bensin, dan layanan-layanan yang lain. 

 
Menemukan sebuah ‘Waypoint’ 

1. Tekan tombol FIND, halama “Find Page” aka tampil. Sorot waypoint dan tekan ENTER 

2. Tekan tombol ROCKER untuk memilih daftar dan sorot waypoint yang ingin Anda temukan, 

tekan ENTER. Halaman ‘Waypoint Information’ akan muncul 

3. Gunakan tombol ROCKER untuk menyorot ‘MAP’ dan tekan ENTER jika Anda ingin melihat 

waypoint pada peta. 

 
Halaman waypoint memuat seluluh ‘waypoint’ (titik) yang telah Anda tAndai (buat). Tekan 

tombol ENTER untuk memilih sebuah waypoint kemudian pilih “Map” untuk melihat waypoint di 

halaman peta atau pilih “Go To” untuk membuat rute. Rute akan muncul pada halaman peta sebagai 

sebuah garis hitam dari titik Anda semula ke waypoint. 
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MEMBUAT RUTE (Route) 

Sebuah rute memberikan Anda penunjuk garis lurus dari satu titik ke titik lain, atau satu titik 

ke beberapa titik lain. Anda dapat membuat sebuah rute sederhana dengan menemukan sebuah 

waypoint dan memilih “Go To” (lihat juga cara menemukan tempat). Anda juga bisa membuat rute 

yang lebih kompleks mencakup beberapa titik. 

 
 
 
 
 
 
 
 
 

 
Membuat Sebuah Rute 

1. Tekan ‘PAGE’ samapai Anda melihat halaman menu utama. Gunakan tombol ROCKER untuk 

menyorot rute dan tekan ENTER. Kemudian tekan ENTER lagi untuk membuat rute baru. 

2. Sorot <Select Next Point> dan tekan ENTER untuk menambahkan sebuah Titik pada rute 

Anda, ‘FIND PAGE’ akan muncul. 

3. Temukan sebuah waypoint atau titik lain untuk menambah titik pada rute Anda. Ketika Anda 

telah menemukan sebuah titik, pillih ‘USE’ dari halaman ‘POINT INFORMATION’ untuk 

menambaha titik ke dalam rute Anda. 

4. Ulangi langkah ke-2 dan ke-3 untuk menambah titik-titik dalam rute Anda. Ketika Anda telah 

selesai menambahkan titik, sorot ‘NAVIGATE’ dan tekan ENTER utnuk memulai 

menggunakan rute. 

 
Menghitung Luas Suatu Area 

Untuk menghitung luas suatu area, tekan tombol Menu dua kali dan akan muncul Halaman 

Utama, pilih Setup kemudian tekan tombol Enter. Pilih Menu Page Seq. Lalu tekan Enter  Add Page 

 Enter, kemudian pilih Area Calculation. Dengan begitu halaman GPS anda bertambah satu yaitu 

Halaman untuk mengukur luas area. 
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Transfer/ Download Data dari GPS ke Komputer 
 
 

MapSource Trip & Waypoint Manager 

MapSource adalah software yang dipakai untuk transfer dan upload data di GPS Garmin. 

Dengan sofware ini kita bisa menyimpan data dari GPS ke komputer dan kita juga bisa mengupload 

data peta, waypoint atau route ke GPS. 

Langkah untuk transfer data dari GPS ke Komputer dengan menggunakan software 

Mapsource adalah sebagai berikut : 

1. Pasang kabel data USB / RS-232 (Serial) dari GPS ke Komputer. 

Catatan ! : Sebelumnya USB Driver harus sudah terinstal di komputer Anda, Driver USB akan 

otomatis terinstal disaat pertama kali GPS dan Komputer dihubungkan dengan USB 

 

2. Buka Program Mapsource : START  All Programs  Garmin  Mapsource 

 

3. Buat file baru, pilih File  NEW 
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4. Untuk mendowanload data dari GPS, pilih Transfer  Receive From Device 

5.  Untuk Mentranfer Peta, Waypoint, atau Route dari Komputer ke GPS, 

pilih Transfer  Send To Device 

  

6. Tunggu sampai komputer mendeteksi GPS yang akan kita download 

7. Pilih data yang akan didownload atau ditransfer (Map, Waypoint, Route, Track), klik Receive 

untuk mendownload atau klik Send untuk men-Transfer. 
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BAB II 

TAHAPAN PRAKTIKUM SIG TINGKAT DASAR 
 
 

Secara umum, tahapan praktikum SIG ini meliputi: (1) INPUT/PEMASUKAN DATA, (2) 

PEMROSESAN DATA, DAN (3) OUTPUT/PENGELUARAN DATA. 

 
1. PEMASUKAN (INPUT) DATA 

Software yang digunakan dalam modul ini adalah ARCVIEW 3.2 
 

Tampilan dalam software Arcview 3.2 

 

Framework dalam software Arcview 3.2 
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Keterangan : 

VIEWS : untuk melakukan pemrosesan baik input (digitasi) maupun pemodelan (overlay) 

TABEL : untuk engedit tabel dari feature (misal : memberi nama Kecamatan, jalan, dsb) 

LAYOUT : untuk melakukan layout peta (pemberian judul, legenda, skala) agar peta siap diolah 

 
REGISTRASI DATA GAMBAR (IMAGE) 

1. Masuk menu View 

2. Data image yang umum digunakan adalah format *.JPEG, *.TIFF,  *.BMP, dan 

*.BIL. 

3. Untuk membuka file berformat *, JPEG, sebelumnya aktifkan  dahulu  ekstensi  

untuk data JPEG, dengan cara membuka menu file pada menu bar, dan  pilih 

extensions. Lalu tandai pada ekstensi JPEG (JFIF)  Image  Support,  dan  kemudian 

klik tombol OK 

 
4. Klik menu Views > AddTheme 

 
 

5. Pada jendela “Add Theme”, gantilah data source type dengan Image Data Source, kemudian 

pilihlah file gambar yang akan dibuka. 



PANDUA 
PENGENALAN GPS DAN PENYUSUNAN B 

N PRAKTIKUM SIG 1: 
BASIS DATA SPASIAL 

 

 

15 

Koordinat 

llayar 

 
 

 
 

6. Gambar yang telah dipilih 

memiliki koordinat) 

tersebut akan tampil pada View dengan koordinat layar (belum 

 
 
 

7. Agar mempunyai koordinat (baik itu koordinat Geografis maupun UTM) maka dilakukan 

Registrasi dengan cara melakukan input koordinat. 
 
 

8. Klik menu File > Extentions > beri tanda centang pada Register and Transform Tool 

Koordinat 

llayar 
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9. Untuk memunculkan Registrasi 

Klik menu View > Register and Transform 

 

10. Proses registrasi dilakukan dengan cara menempatkan peta sedemikian rupa dengan 

memanfaatkan icon Zoom dan Pan 

 

Zoom(+)   Zoom(-) Pan 

 
 
 

11. Membuat titik kontrol koordinat X, Y dengan klik tanda , kemudian isilah koordinatnya 

sesuai dengan yang tertera pada gambar peta (pada contoh ini menggunakan koordinat UTM). 



PANDUA 
PENGENALAN GPS DAN PENYUSUNAN B 
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Titik Koordinat 

 
 
 
 

 
Membuat 

Titik 
Koordinat 

 
 
 
 
 
 
 
 
 
 
 

 

12. Buatlah titik kontrol sebanyak 4 buah 

 
 

13. Simpan titik kontrol 

Klik Write Word File > OK (langsung tanpa merubah nama file ataupun direktori) 

Titik Koordinat 



PANDUA 
PENGENALAN GPS DAN PENYUSUNAN B 

N PRAKTIKUM SIG 1: 
BASIS DATA SPASIAL 
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14. Tutup jendela View dan buka jendela View baru 

Buka file gambar yang baru saja dikoreksi pada alamat direktori yang sama. 
 

 

15. Peta yang muncul sudah terkoreksi dan memiliki koordinat UTM. 
 

Koordinat 

peta 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

16. Buka View > Properties 

17. Setting seperti dibawah ini untuk merubah unit satuan pada view. 



PANDUA 
PENGENALAN GPS DAN PENYUSUNAN B 

N PRAKTIKUM SIG 1: 
BASIS DATA SPASIAL 
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Titik 

Garis lurus 

Garis mengikuti garis 

Poligon kotak 

Poligon lingkaran 

Poligon bebas 

Memotong garis 

Memotong poligon di dalam 

Menambah poligon 

Titik 

Garis lurus 

Garis mengikuti garis 

Poligon kotak 

Poligon lingkaran 

Poligon bebas 

Memotong garis 

Memotong poligon di dalam 

Menambah poligon 

 
 

DIGITASI POLIGON 

18. Buat tema baru yang akan di digitasi 

Klik View > New Theme 

 

19. Pilih Poligon 

20. Digitasi poligon menggunakan fasilitas yang ditandakan oleh icon seperti terlihat pada gambar 
 

 

21. Gunakan tombol untuk memulai mendigitasi peta. 

22. Ikuti kenampakan di peta dengan cara mengklik berulang-ulang 

23. Apabila digitasi telah sampai pada tepi layar, Klik kanan > Pan untuk menggeser tampilan 
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Garis 

terluar 

Klik dua kali pada warna 

Klik Apply 

simbol Klik dua kali pada warna simbol 

Muncul 

Dipilih 

Diganti 3 

Klik Apply 

 

 

24. Untuk membuat sub poligon dapat dilakukan dengan klik icon 

25. Buatlah peta menjadi transparant dengan cara double click pada layer theme di sebelah kiri 

jendela view. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

26. Mulailah digitasi dengan memulai pada garis terluar dan mengakhiri pada garis terluar juga 

(klik dua kali) 

 

Garis 

terluar 

Garis 

terluar 
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Titik 

Garis lurus 

Garis mengikuti garis 

Poligon kotak 

Poligon lingkaran 

Poligon bebas 

Memotong garis 

Memotong poligon di dalam 

Menambah poligon 

Titik 

Garis lurus 

Garis mengikuti garis 

Poligon kotak 

Poligon lingkaran 

Poligon bebas 

Memotong garis 

Memotong poligon di dalam 

Menambah poligon 

 
 

DIGITASI GARIS 

27. Buat tema baru yang akan di digitasi 

Klik menu View > New Theme 

 

28. Pilih Line 
 

 
29. Digitasi garis menggunakan 

Terdapat dua fasilitas untuk memulai digitasi yaitu: 

-   draw line,  untuk memulai digitasi  garis 

-   draw line to split feature , untuk melanjutkan digitasi garis yang terputus. 
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EDITING PETA 

Proses Clean 

Proses clean bertujuan untuk membangun topologi dan membersihkan atau mengurangi 

kesalahan yang berasal dari proses digitasi, seperti garis yang saling berpotongan ( overshoot ) atau 

garis yang tidak tersambung ( undershoot ). 

Untuk proses ini dalam Arc View, digunakan extensions Edit Tool (ET). Untuk 

mengaktifkannya, sama dengan langkah  sebelumnya.  Setelah  diaktifkan  akan  

muncul icon  edit tool (  ). Untuk menggunakan modul edit tool, klik pada icon ET, 

sehingga muncul jendela Edit Tools dengan sub-sub menu ET seperti ditunjukkan 

pada gambar dibawah ini. 

Gambar Tampilan Menu Edit Tool dan toolbar sub menu edit theme pada ET 

 

 
Untuk melakukan proses-proses editing yang salah satunya adalah  proses 

clean, pilih sub menu edit theme . Kemudian muncul kembali sub  menu  dari  menu 

edit theme.  Dalam toolbar edit theme tersebut  terdapat  berbagai  proses  editing  

yang salah satunya terdapat sub menu clean. Gunakan sub  menu clean untuk 

melakukan proses clean tersebut. Yang perlu diperhatikan adalah setting fuzzy 

tolerance yang menentukan dalam proses penyambungan garis  dan  penghilangan 

garis yang berpotongan pada saat proses clean. Besarnya fuzzy tolerance sangat 

tergantung pada skala peta yang akan kita buat  dan  juga  tergantung  pada  satuan 

unit pemetaan yang kita buat ( metric atau derajat).  
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30. Setelah proses clean selesai, selanjutnya dilakukan editing kesalahan (dangle) dengan 

mengaktifkan extensi Edit Tools. Klik File > Extension > 

 

31. Aktifkan extensi Edit Tools dengan mengklik sampai muncul  tanda centang 

32. Aktifkan Edit Tools pada view. 
 

33. Muncul menu seperti gambar dibawah, selanjutnya klik Edit Theme kemudian Show Edit Tools 
 

 

34. Untuk editing kesalahan (dangle) gunakan fasilitas dengan dengan mengklik icon 
 

 
Menampilkan 

kesalahan 

Meneruskan 

garis 

Menyambung 

garis 
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2. PEMROSESAN DATA 

Input Data Atribut 

35. Klik Open Theme Table untuk membuka tabel atribut peta 

 

36. Klik Table > Start Editing 

37. Klik Edit > Add Field, ganti tiap isian seperti pada contoh dibawah ini, kemudian klik OK 

  
 

38. Klik Windows > Tile 

39. Lakukan memilih kenampakan (warna kuning) dengan klik icon  

 

40. Memberi nama Kecamatan dengan klik icon 
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41. Lakukan untuk semua Jenis Tanah yang ada. 

42. Bila sudah selesai klik Table > Stop Editing kemudian Yes 

43. Kembali ke View dan klik icon     (Clear Selected Feature) untuk menghilangkan area terpilih 

(warna kuning) 

44. Pada Legend Editor (kik dua kali pada nama Batas) diganti seperti di bawah ini kemudian Apply 

 
 

 

45. Untuk memunculkan label, 

Keterangan 

Klik Theme > Auto Label kemudian Label Field diganti dengan 

Untuk mengganti huruf, arahkan kursor dihuruf kemudian klik Ctrl + P (pada huruf) 

46. Lakukan Hal yang sama untuk kenampakan 

Jalan (nama file baru Jalan) Feature type > Line 

Sungai (nama file baru Sungai) Feature type > Line 
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Titik 
Garis 
 

Area 

 
 

3. PENGELUARAN (OUTPUT) DATA 
 
 

47. Atur peta sedemikian rupa. Diurutkan kenampakan Titik ---- Garis ----- Area (Harus urut dari atas 

ke bawah dan ini merupakan aturan baku) 

 
 

48. Klik View > Layout kemudian OK 

 

49. Klik Layout > Properties, hilangkan tanda centang di Snap to grid untuk memudahkan dalam 

perpindahan obyek 
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50. Klik Layout > Page Setup dan atur sedemikian rupa 

51. Menggambar dan mengatur dengan menggunakan fasilitas yang ada. 
 
 
 
 
 

 
Membuat Teks Lurus (contoh judul) 

 
 

Membuat Teks Mengikuti Garis 

(contoh nama sungai 

 
 
 
 
 

 
Membuat Titik 
Membuat Garis Lurus 
Membuat Garis Berkelok-kelok 
Membuat Poligon Kotak 
Membuat Poligon Lingkaran 
Membuat Poligon Bebas 

 
 
 
 
 
 

Memasukkan Peta dari View 

Membuat Legenda 

Membuat Skala 

Membuat Orientasi 

Membuat Chart 

Membuat Grid 

Memasukkan Gambar Format BMP (Contoh Simbol 

Perusahaan 
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52. Pengaturan skala tampilan peta pada kertas dengan klik 2 kali pada peta. 

53. Untuk memecah (seperti ungroup) Legenda agar bisa diedit 

Klik Graphics > Simplify 

54. Pengaturan Skala Bar peta dengan Klik 2 kali pada Skala Bar. Atur sedemikian rupa. Apabila skala 

terlalu besar dapat dikecilkan dengan cara menggeser. 

 
 
 

55. Memberikan Koordinat 

Klik File > Extentions beri tanda centang Graticules and Measured Grids 
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56. Klik icon dan atur seperti di bawah ini 
 

 
 

Klik Preview kemudian klik Finish 

57. Tampilan peta setelah di layout 
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58. Peta siap dicetak 

 

59. Apabila peta ini akan dirubah dalam format gambar (raster) Klik File > Export 
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BAB III 

PEMODELAN SIG DENGAN GEOPROCESSING (OVERLAY) 
 
 

3.1. Analisis Arahan Fungsi Pemanfaatan Lahan 

Luntungan (1998) menjelaskan bahwa arahan fungsi pemanfaatan lahan merupakan kajian 

potensi lahan untuk peruntukan suatu kegiatan ke dalam suatu kawasan tertentu berdasarkan fungsi 

utamanya. Arahan fungsi pemanfaatan lahan juga dapat diartikan sebagai upaya untuk menata 

pemanfaatan lahan pada suatu kawasan sesuai dengan kemampuannya Dalam hal ini tujuan dari 

arahan fungsi pemanfaatan lahan adalah untuk mencapai keseimbangan antara kemampuan lahan 

dengan jenis pemanfaatan dan teknologi yang digunakan sebagai upaya untuk melindungi 

kelangsungan fungsi dan manfaat sumberdaya alam di suatu wilayah. Artinya apabila penggunaan 

lahan pada masing-masing kawasan tidak sesuai dengan fungsi utamanya maka perlu dilakukan 

tindakan arahan fungsi pemanfaatan lahan dengan menerapkan tindakan rehabilitasi lahan dan 

konservasi tanah secara vegetatif dan mekanik yang bertujuan untuk mengembalikan dan menjaga 

fungsi utama kawasannya. 

Salah satu alternatif yang dapat digunakan dalam menentukan arahan fungsi pemanfaatan 

lahan adalah dengan menggunakan Sistem Informasi Geografis (SIG). SIG merupakan sistem yang 

dapat mendukung pengambilan keputusan spasial dan mampu mengintegrasikan deskripsi-deskripsi 

lokasi dengan karakteristik-karakteristik fenomena yang ditemukan di suatu lokasi. Berdasarkan 

definisi di atas, SIG sangat tepat digunakan sebagai alat analisis dalam menentukan arahan fungsi 

pemanfaatan lahan di suatu wilayah. 

Fungsi kawasan merupakan pemintakatan lahan berdasarkan karakteristik fisiknya berupa 

lereng, jenis tanah dan curah hujan harian rata-rata menjadi kawasan lindung, penyangga, budidaya 

tanaman tahunan dan budidaya tanaman semusim, dimana setiap kawasan mempunyai fungsi 

utama yang spesifik. Berikut ini adalah kriteria yang digunakan Balai Rehabilitasi Lahan dan 

Konservasi Tanah (BRLKT), Departemen Kehutanan untuk menentukan status kawasan berdasarkan 

fungsinya : 

a. Kawasan Fungsi Lindung 

Satuan lahan dengan jumlah skor ketiga karakteristik fisiknya sama dengan atau lebih besar 

dari 175, atau memenuhi salah satu atau beberapa kriteria sebagai berikut : 

1) Mempunyai kemiringan lereng lebih > 45 % 

2) Merupakan kawasan yang mempunyai jenis tanah sangat peka terhadap erosi (regosol, 

litosol, organosol,dan renzina) dan mempunyai kemiringan lereng > 15% 
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3) Merupakan jalur pengaman aliran sungai sekurang-kurangnya 100 meter di kanan kiri 

alur sungai 

4) Merupakan wilayah sekitar mataair, yaitu 200 meter dari pusat mataair. 

5) Berada pada ketinggian lebih atau sama dengan 2.000 meter diatas permukaan laut. 

b. Kawasan Fungsi Penyangga 

Satuan lahan dengan jumlah skor ketiga karakteristik fisiknya antara 125-174 serta 

memenuhi kriteria umum sebagai berikut: 

1) Keadaan fisik satuan lahan memungkinkan untuk dilakukan budidaya. 

2) Lokasinya secara ekonomis mudah dikembangkan sebagai kawasan penyangga. 

3) Tidak merugikan segi-segi ekologi atau lingkungan hidup apabila dikembangkan sebagai 

kawasan penyangga. 

c. Kawasan Fungsi Budidaya Tanaman Tahunan 

Satuan lahan dengan jumlah skor ketiga karakteristik fisiknya < 124 serta sesuai untuk 

dikembangkan usaha tani tanaman tahunan. Selain itu areal tersebut harus memenuhi kriteria 

umum untuk kawasan penyangga. 

d. Kawasan Fungsi Budidaya Tanaman Semusim dan Permukiman 

Satuan lahan dengan kriteria seperti dalam penetapan kawasan budidaya tanaman tahunan 

serta terletak di tanah milik, tanah adat dan tanah negara yang seharusnya dikembangkan usaha tani 

tanaman semusim. Selain memenuhi kreteria tersebut diatas, untuk kawasan permukiman harus 

berada pada lahan yang memiliki lereng mikro tidak lebih dari 8%. 

 

Dalam SIG, fasilitas yang dapat digunakan untuk melakukan analisis arahan fungsi 

pemanfaatan lahan adalah tumpangsusun (overlay) peta dengan geoprocessing. Pada dasarnya, 

overlay peta adalah suatu proses menggabungkan beberapa tema peta (baik data grafis maupun 

data atribut) menjadi satu untuk menghasilkan informasi baru. Sebagai ilustrasi dapat di lihat pada 

Gambar 1 berikut: 

IINNPPUUTT DDAATTAA PPEETTAA 

 
Lereng 

AANNAALLIISSAA SSPPAASSIIAALL IINNFFOORRMMAASSII BBAARRUU 

 

Tanah 
OOvveerrllaayy 

 

Hujan 
 
 

INFORMASI ARAHAN FUNGSI 

PEMANFAATAN LAHAN 

 

Gambar 3.1. Ilustrasi Proses Tumpangsusun (overlay) Peta 

KRITERIA/PERATURAN 
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Adapun langkah-langkah proses overlay peta menggunakan perangkat lunak SIG ArcView 

adalah sebagai berikut: 

1. Buka ArcView dan aktifkan ekstensi Xtools 

Klik File > Extention 

 

2. Buka peta tanah, lereng, dan intensitas curah hujan 
 

3. Buka atribut dan tambahkan field baru (type number) 

 
 
 

4. Lakukan skor untuk tiap peta seperti ketentuan pada Tabel 3.1, 3.2, dan 3.3 berikut: 
 



 

 

34 

 
 

Tabel 3.1. Klasifikasi dan Pemberian Nilai Skor Kemiringan Lereng 
 

Kelas Kemiringan (%) Klasifikasi Nilai Skor 

I 0,00 – 8,00 Datar 20 

II 8,01 – 15,00 Landai 40 

III 15,00 - 25,00 Agak Curam 60 

IV 25,01 - 40,00 Curam 80 

V 40,01 atau lebih Sangat Curam 100 

 
Tabel 3.2. Klasifikasi dan Pemberian Nilai Skor Curah Hujan Harian Rata 

 

Kelas Intensitas (mm/hari) Klasifikasi Nilai Skor 

I s/d – 13,60 Sangat Rendah 10 

II 13,61 – 20,70 Rendah 20 

III 20,71 – 27,70 Sedang 30 

IV 27,71 – 34,80 Tinggi 40 

V 34,81 atau lebih Sangat Tinggi 50 

 
Tabel 3.3. Klasifikasi dan Pemberian Nilai Skor Jenis Tanah 

 

Kelas Jenis Tanah Klasifikasi Nilai Skor 

I 
Aluvial, Gleisol,Planosol, Hidromorf 

kelabu, Laterik 
Tidak Peka 15 

II Latosol Kurang Peka 30 

III 
Brown forest soil, non calcic brown, 

mediteran 
Agak Peka 45 

IV 
Andosol, Laterit, Podsol, Grumusol, 

Podsolik 
Peka 60 

V Regosol, Litosol, Organosol, Renzina Sangat Peka 75 

 
5. Lakukan overlay peta menggunakan fasilitas geoprocessing 

Klik File > Extention > beri tanda centang pada geoprocessing 
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6. Overlay peta lereng dan tanah menggunakan fasilitas intersect 

Klik View > Geoprocessing Wizard > Intersect 

7. Overlay peta hasil dengan peta hujan (masih menggunakan fasilitas intersect 

8. Buka atribut peta hasil akhir overlay antara peta lereng, tanah, dan hujan. 

9. Tambahkan field baru dengan nama skor_tot (type number), kemudian isilah dengan hasil 

penjumlahan antara skor lereng, skor tanah, dan skor hujan menggunakan fasilitas calculate 

 
 
 

10. Klasifikasikan hasil skor total menjadi kelas arahan fungsi pemanfaatan lahan sesuai dengan 

ketentuan yang ada pada Tabel 3.4 berikut: 

Tabel 3.4. Klasifikasi Arahan Fungsi Pemanfaatan Lahan 
 

 

Kriteria 
Arahan Fungsi 

Pemanfaatan Lahan 

Skor Total > 175 Kawasan Lindung 

Skor Total 125 - 175 Kawasan Penyangga 

Skor Total 0-124, dan lereng lebih besar 8% Kawasan Budidaya Tanaman Tahunan 

Skor Total 0-124, dan lereng sama dengan 

atau lebih kecil dari 8% 

Kawasan Budidaya Tanaman Semusim dan 

Permukiman 

 
11. Lakukan Proses Logika pada menu Query 
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Menu Calculate (Ka 

Query Calculate (kalulator ) 

Klik New Set 

memilih area y 

mempunyai sk 

alkulator) 

untuk 

ang 

or > 175 

Query Calculate (kalulator) 

 
 
 
 
 
 

Klik New Set untuk 

memilih area yang 

mempunyai skor > 175 

 
 

 

12. Bila telah di New Set maka masuk menu Calculate dan ditulisi “Kawasan Lindung” (Harus Pakai 

Tanda Kutip) 

 
 
 

 
Proses Logika pada SOFWARE 

 

Menu Query Menu Calculate (K lkulator) 

( [Skortotal] > 175 ) “Kawasan Lindung” 

( [Skortotal] >= 125) and ([Skortotal] <= 175 ) “Kawasan Penyangga” 

( [Skortotal] <= 124) and ([Skorlereng] > 40 ) 
“Kawasan Budidaya Tanaman 
Tahunan” 

( [Skortotal] <= 124) and ([Skorlereng] <= 40 ) 
”Kawasan Budidaya Tanaman 
Semusim dan Permukiman” 
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Contoh Peta Hasil Analisis Arahan Fungsi Pemanfaatan Lahan di DIY 

 
 

3.2. Monitoring Perubahan Penggunaan Lahan 

Overlay peta dalam SIG, seperti yang telah disebutkan sebelumnya merupakan suatu proses 

untuk menggabungkan dua tema peta atau lebih sehingga dihasilkan sebuah informasi baru. Selain 

itu dengan menggabungkan beberapa peta, kita juga dapat membandingkan secara langsung antara 

peta yang satu dengan peta yang lainnya baik yang memiliki liputan wilayah sama tema berbeda, 

liputan wilayah berbeda namun temanya sama, maupun liputan wilayah yang sama dengan tema 

yang sama pula. Biasanya proses membandingkan antara peta yang satu dengan peta yang lainnya 

sering dilakukan dalam kegiatan monitoring, salah satunya adalah monitoring perubahan penutupan 

lahan atau penggunaan lahan. 

Monitoring perubahan penggunaan lahan dilakukan untuk mengetahui perubahan 

penggunaan lahan yang terjadi antara tahun pertama (T1) dengan tahun kedua (T2), sehingga dapat 

diketahui perubahan luas tiap penggunaan lahan dari waktu ke waktu. Syarat dalam melakukan 

analisis monitoring perubahan penggunaan lahan ini adalah kedua peta penggunaan lahan (PL) 

memilki liputan wilayah yang sama serta memiliki klasifikasi penggunaan lahan yang sama/setara. 

Hal ini diperlukan agar proses analisisnya dapat dilakukan dengan cepat dan mudah. 

Proses monitoring PL masih dlakukan dengan memanfaatkan fasilitas geoprocessing pada 

perangkat lunak ArcView untuk meng-overlay peta PL T1 dan peta PL T2. Sebagai ilustrasi, proses 

monitoring PL ini dapat dilihat seperti pada Gambar 3.2. 
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PL T1 PL T2 Hasil Overlay 
 
 
 
 

Gambar 3.2. Ilustrasi grafis hasil overlay penggunaan lahan pada tahun yang berbeda 

Adapun langkah-langkah dalam melakukan monitoring perubahan PL menggunakan 

perangkat lunak ArcView adalah sebagai berikut : 

1. Aktifkan Ekstensi Geoprocessing 

2. Buka dan Tampilkan kedua file peta digital PL1 dan PL2 

3. Bukalah tabel atribut kedua theme tersebut . 

4. Lakukan perintah pada Menu: View > Geoprocessing Wizard 

5. Ketika sudah tampil Jendela Geoprocesing, pilih pada radio button “Intersect Two Theme”, klik 

Next untuk melanjutkan pada jendela berikutnya 

 
 

6. Lanjutkan dengan memilih theme yang akan dioverlay yaitu PL1 dan PL2, serta simpanlah 

hasilnya pada direktori yang sama dengan nama PL1_PL2, klik Next. 
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7. Tekan Finish, tunggu beberapa saat hingga proses selesai 

8. Bukalah atribut hasil overlay tersebut dan perrhatikan bahwa informasi kedua theme tersebut 

tampil pada setiap satuan hasil overlay. 

 
Tugas : 

1. Bandingkan dan buatlah tabel dua dimensi yang menunjukkan perubahan penggunaan lahan 

yang terjadi. 

2. Hitung dan Catatlah luas tiap satuan hasil overlay dengan menggunakan query pada modul  

tabel. 

 
 
 

Tabel 3.5. Luas Perubahan Penggunaan Lahan PL1 dan PL2 
 

PL1/PL2 H Kc Pekr Pmk S Sm Tg 

H        

Kc        

Pekr        

Pmk        

S        

Sm        

Tg        

 


